Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/proekt/public_html/ishutdownapp.com/forum/Sources/Load.php(225) : runtime-created function on line 3
Same 3G issues as most others here
iShutdown forum
November 17, 2017, 07:50:58 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Follow us on twitter @iShutdown
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Same 3G issues as most others here  (Read 5065 times)
Islander
Newbie
*
Posts: 2


View Profile Email
« on: May 04, 2013, 01:37:34 PM »

Hello-Overall, I like the app. It Took awhile for me to get my router settings configured correctly, but with my Linksys E3000, setting all the port forwarding for WOL, and this app correctly, along with setting up a dyndns account, I can get my computer to follow commands perfectly with the app via LAN. I can even change my iPhone over to 3G and have found that I can get the PC to sleep or power off using the (Favorite Button).

Once the computer goes to sleep though, I only have been able to get it to turn back on once via 3G/internet. I have tried different ways, but the app will say command sent...but nothing. If I change my iPhone back to Wi-Fi-it works perfectly. any answers?

I was wondering if installing the apps window server as a service and deleting the application would perhaps make the app function better?
Also to update. I can turn my iPhone 3G on and reboot the pc without issue using the app. the problem is when the computer turns off or goes to sleep, I am unable to wake on Lan or restart via the internet. If I use my LAN, everything works perfectly.
« Last Edit: May 04, 2013, 02:37:30 PM by Islander » Logged
Vlad Polyanskiy
Administrator
Full Member
*****
Posts: 229


View Profile Email
« Reply #1 on: May 06, 2013, 03:09:29 AM »

Hi, sorry for so long waiting. I had a lot of work.

So. The trouble is when you try to Wake your PC from internet it doesn't work?
If so the 1st thing you should try is to forward incoming Magic packet to your internal broadcast address
It's a adress like X.X.X.255 (for example 192.168.1.255 or 192.168.0.255)
if your router enables that feature for you, then you will be able to Wake your PC via internet.
please try it and tell me about results.
Logged
Islander
Newbie
*
Posts: 2


View Profile Email
« Reply #2 on: May 06, 2013, 08:48:58 AM »

Hi Vlad-Ty for the reply. Unfortunately with my Linksys E3000, Cisco disables setting the ip to the broadcast address of 255 for security. I tried using a tweak fix I found on YouTube where you could use a Firefox plugin called Dom inspector to actually change the value, but I was not able to get it to work either. I really do not want to use the dd-wrt firmware, but I am thinking to get the 3g function to work, I may have to.

Like I said, Using the app over LAN, all the functions work correctly. If I change my iPhone over to 3g while my computer is on, I can use the app and click reboot, and it will work. I can even put the computer to sleep using 3g. The issue is turning the computer back on using the 3g.
Logged
Vlad Polyanskiy
Administrator
Full Member
*****
Posts: 229


View Profile Email
« Reply #3 on: May 07, 2013, 03:05:17 AM »

Please take a lokk at this video may be it will help you
http://www.youtube.com/watch?v=lWodv1Kq08A
Logged
BluesRiff
Newbie
*
Posts: 6


View Profile
« Reply #4 on: June 17, 2013, 10:01:35 AM »

I have the same issue with WOL not working over 3G. I have Port 9 forwarded to the machine I am trying to start and can start it no problem with my other WOL apps using my DynDns address. Similar to others I can do all the other power functions over the internet except WOL. WOL does work fine over the local LAN. Just to be clear I have the local fixed IP address of the machine in the 'IP-address or DNS name field' MAC address in the 'Mac-Address' field, a Host description and the DynDNS name in the 'External IP or DNS Name' field. I have entered this address without the HTTP prefix and assume it's ok as the shutdown works fine.

I also have a magic packet monitor running and can see the magic packet from my other software arrive but nothing from iShutdown HD.

Also how does iShutdown know which port to use for the magic packet, or does it only default to 9?

Regards

Steve
Logged
tyrantlake
Newbie
*
Posts: 16


View Profile
« Reply #5 on: June 17, 2013, 08:20:13 PM »

Using the WOL over 3G takes time to setup correctly. The biggest issue is setting the port forwarding.  What is your router model? Does it support the internal broadcast address 192.168.1.255 in the port forwarding screen in your router setup?

The best way to describe how the magic packets work is that it sends a message to your ip to turn on your pc, but when you are not on your network and you are sending it to your pc e.g. 192.168.1.22 that if off that pc doesn't have an ip at that time. So the magic packet should be sent to 192.168.1.255, which is the broadcast address. Now internet originated magic packets will be broadcast to all devices on your network, but only the machines with the correct MAC address within that packet will respond.

Your port forwarding rule should be UDP  9   9  192.168.1.255 and not the ip of the pc you are trying to connect.

I hope this helps you out.
Logged
BluesRiff
Newbie
*
Posts: 6


View Profile
« Reply #6 on: June 18, 2013, 12:24:38 AM »

Hi

My router doesn't support the broadcast mode but I have a fixed IP for the machine to which the port is forwarded and I have no problem starting it with another WOL app in fact I have a couple of WOL apps which work fine so I don't think it's the router. I would like to use this app because it support shutdown which does work fine.
Logged
tyrantlake
Newbie
*
Posts: 16


View Profile
« Reply #7 on: June 18, 2013, 05:04:55 AM »

Did you watch the video link that Vlad posted several posts up? For my setup I needed the broadcast address to get it to work. Maybe try the Firefox DOM Inspecter addon to see if this could help you?

I have a router running Tomato firmware, that has a way of getting the broadcast address to work on my router. You never provided your router model?
Logged
BluesRiff
Newbie
*
Posts: 6


View Profile
« Reply #8 on: June 21, 2013, 07:58:38 AM »

I'm stuck with the router I have which is a Livebox by Sagem as this supportsx some ISP specific functionality, and this router doesn't support broadcast. However given no problem forwarding in the Magic Packet using other WOL apps I don't think it's the router setup.
Logged
tyrantlake
Newbie
*
Posts: 16


View Profile
« Reply #9 on: June 21, 2013, 10:57:13 AM »

I find it hard to believe you have other applications that you are able to use WOL with your router where everything I have read says that router is not capable of WOL? You can use 3G or are you only using your LAN with these apps? Can you use this website to wake your pc? http://www.wolcenter.com/home.php

If these other apps are able to use 3G then use them to wake your pc and when you are ready to shutdown your pc use iShutdown?

The only other solutions I found was adding an additional router to your setup that allows direct broadcast address. Not the solution you were looking for I know.

http://www.dslreports.com/forum/r20793158-SOLUTION-Wake-on-Lan-Orange-Livebox-Port-Forwarding-

At this time (2009/08), liveboxes Sagem and Inventel do not support wake on LAN, neither natively, nor via an UDP broadcast forward. In other words, as far as I know, it is impossible to send a magic packet over the Internet throuth a livebox gateway. The only known workaround is to use a third device located on the same LAN able to forward an UDP broadcast packet.
Logged
BluesRiff
Newbie
*
Posts: 6


View Profile
« Reply #10 on: June 23, 2013, 04:44:04 AM »

To be clear the WOL works over 3G with other apps before the router ARP cache gets flushed it didn't work with iShutdown. I have resolved the issue by adding an old Sony VGN UX180P handheld to the LAN and leaving this permanently on as it takes very little power and can survive power outages for a couple of hours on battery. I put a LAN WOL app on the Sony so I can RDP to it then wake any PC on my LAN from there. For shutdown I just use the RDP app to the PC in question and use a shortcut to the 'shutdown.exe -s -t 00' command. So IShutdown no longer required. Thanks for your contribution.
Logged
BluesRiff
Newbie
*
Posts: 6


View Profile
« Reply #11 on: June 23, 2013, 05:45:13 AM »

One final note.

Investigating a bit further with a network sniffer the only way it seems that a full WOL packet is sent including the DNS and Port is if the 'Wake On Lan all' option is used at the bottom of the 'hosts' list. 

The 'play arrow' on the graphic input screen seems to only sends a magic packets to LAN broadcast and the local IP of the device so can't be used over 3G.

So the internet WOL does work via the default port of 9 if the 'Wake On Lan all' option is selected.
Logged
Vlad Polyanskiy
Administrator
Full Member
*****
Posts: 229


View Profile Email
« Reply #12 on: June 23, 2013, 10:40:11 PM »

tyrantlake,
Thank you for your time and answers.

BluesRiff,
Thank you for the info about 'WOL all' feature. It might be a bug. I'll check and fix it if so.
Logged
BluesRiff
Newbie
*
Posts: 6


View Profile
« Reply #13 on: October 06, 2013, 02:36:05 AM »

Just a note for others who may be having problems with the flushed ARP table. If your NIC has an ARP offload capability it will respond to an ARP request from the router even if it has been flushed from the ARP table in the router. This functionality is set in the NIC properties and the machine must be in sleep mode not off. As power consumption is similar in the Off and Sleep modes this works fine for my machines.
Logged
Vlad Polyanskiy
Administrator
Full Member
*****
Posts: 229


View Profile Email
« Reply #14 on: October 24, 2013, 01:52:40 AM »

Thank you for patience.

Do you still have troubles with the new version of iShutdown 3.0.1?
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!