Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/proekt/public_html/ishutdownapp.com/forum/Sources/Load.php(225) : runtime-created function on line 3
Interesting issue
iShutdown forum
November 17, 2017, 07:54:17 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Facebook page http://facebook.com/iShutdown
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Interesting issue  (Read 4176 times)
vkl
Newbie
*
Posts: 5


View Profile Email
« on: October 25, 2011, 07:23:51 AM »

Hi

Only downloaded and configured iShutdown on WinXP yesterday and so far, very impressed.

However I do have an interesting issue which I wonder if could be addressed.  On my iPhone 4 ios5, iShutdown works properly when I click on the host then choose the WOL or iShutdown commands but when I click on the big button on the home page with my PC off, my PC starts up as normal then loads the windows xp gui, then promptly shuts down (albeit in a proper fashion).

Another interesting issue is that I have the Apple remote app install too and with the PC in an 'off' state when I tap the Apple app, it sends WOL command to PC and starts it up.  I have itunes in the startup folder, the Apple app then connects to it and works perfectly.  I can then use iShutdown to turn off PC.  This works very well for me in my situation because I only use the PC as a media server.  Just thought I'd let you know.

Logged
Vlad Polyanskiy
Administrator
Full Member
*****
Posts: 229


View Profile Email
« Reply #1 on: October 26, 2011, 01:31:08 AM »

As i understand your PC shuts down immediately after it boots up? But only if you start it
via power button on home screen. If you boot it clicked host and select wake on lan all works fine?

Will test it immediately.
Logged
vkl
Newbie
*
Posts: 5


View Profile Email
« Reply #2 on: October 26, 2011, 05:18:30 AM »

Yes that's exactly correct. Just the same in the new version downloaded this morning.
Logged
Vlad Polyanskiy
Administrator
Full Member
*****
Posts: 229


View Profile Email
« Reply #3 on: October 26, 2011, 06:32:41 AM »

Ok. Will try reproduce it.

And please tell me you tap and release power button fast or you hold power button pressed for some time until
diod starts lighting?
Logged
vkl
Newbie
*
Posts: 5


View Profile Email
« Reply #4 on: October 26, 2011, 09:26:34 AM »

Just tap the button fast. No holding down.
Logged
Vlad Polyanskiy
Administrator
Full Member
*****
Posts: 229


View Profile Email
« Reply #5 on: October 27, 2011, 12:34:48 AM »

Its very-very strange. It use the same algorithm to wake up and shutdown both default screen an list screen.

Which type of server software you use? Working as service or as application?

Please try to use long press on restart button to wake up your host and tell me
about results please.
Logged
vkl
Newbie
*
Posts: 5


View Profile Email
« Reply #6 on: October 27, 2011, 01:31:42 AM »

I deleted app, then reinstalled and here's the latest results:

iShutdown installed as a service on XP Pro
iPhone 4 ios5

From host screen WOL works fine
From host screen iShutdown works fine

With PC in off state:
From big button, PC will now not start
But if I use WOL from host screen to start, big button will turn off.
Long press of big button does nothing.

Start Apple remote app on iPhone and PC starts as before.

Cheers, Rob
Logged
Vlad Polyanskiy
Administrator
Full Member
*****
Posts: 229


View Profile Email
« Reply #7 on: October 27, 2011, 05:56:47 AM »

Ok, thank for info.

Please try also long tap on small restart button and tell about results.
it must send both commands on wake up and on shutdown. So it must work
in all host states.
Logged
vkl
Newbie
*
Posts: 5


View Profile Email
« Reply #8 on: October 27, 2011, 06:54:08 AM »

Hi Vlad,

Found a solution. If I remove iTunes from the startup folder on the PC, iShutdown works perfectly. Don't know why this should be but at least problem solved.

Thought it a bit strange how Apple Remote app would start the pc from WOL
Logged
onkelandy
Newbie
*
Posts: 4


View Profile
« Reply #9 on: March 04, 2012, 12:15:09 PM »

Hi!
I'm experiencing the same issue with the ishutdown service 1.0 on Windows 7 64bit.
I also have itunes in my startup folder but as this is necessary removing it is not an option. Windows starts fine but just shuts down again after booting is complete.

It looks like using the normal server tool (not as service) version 1.2 fixes the problem so it's no huge deal - although I have to test that again Wink
Best wishes!
Logged
onkelandy
Newbie
*
Posts: 4


View Profile
« Reply #10 on: March 04, 2012, 01:10:08 PM »

Okay, here I go again.. the problem also exists with the non-service windows tool Sad
Everything is fine when the PC was completely shut down. But when I put it in standy or hibernation this is what happens when I tap the big power button on the iphone app: wake up and shutdown.

Speaking of shutdown: do you see any chance to send a command to all the open applications to close properly before shutting down? Because some software really needs to be closed properly (itunes for example takes several minutes after a shutdown without closing to scan the library again..).

Thanks for your help!
Logged
Vlad Polyanskiy
Administrator
Full Member
*****
Posts: 229


View Profile Email
« Reply #11 on: March 04, 2012, 10:37:48 PM »

Hope it will be fixed with next server update
it will come somewhere in middle march.

I test it now and it looks like that issue fix on
it already (i rewrite many parts of server in last month)
if you want i can send it to you via email when it will stable?
Logged
onkelandy
Newbie
*
Posts: 4


View Profile
« Reply #12 on: March 05, 2012, 03:33:22 AM »

Hi Vlad!
That sounds great and yeah, I would appreciate receiving a stable version via mail.
Thanks and best wishes!
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!